In the world of network engineering, theoretical knowledge is important, but hands-on configuration experience is invaluable. Today, we’ll walk through a real-world example of configuring Multi-Chassis Link Aggregation (MLAG) on Arista switches. This guide will take you through each step of configuring MLAG on a leaf switch in a campus environment, with clear explanations and verification steps along the way.
Essential Show Commands for Troubleshooting
Before we start configuring, let’s familiarize ourselves with the key commands you’ll need for verification:
show mlag # Basic MLAG status
show mlag interfaces # MLAG interface details
show interfaces status # Port-Channel and L2 forwarding status
show mlag detail # Comprehensive MLAG information
show mlag config-sanity # Configuration consistency check
show po # Port-channel information
Pro tip: The show mlag detail
command is particularly valuable as it provides insights into primary/secondary roles and reload delay values – crucial information for maintenance windows.
Step-by-Step Configuration Guide
1. Configuring the MLAG Communication VLAN
First, we’ll set up the Layer 2 VLAN that MLAG peers will use to communicate:
configure
vlan 4094
trunk group MLAG
no spanning-tree vlan-id 4094
Important note: While we’re using VLAN 4094 here, you can choose any VLAN number. The crucial requirement is that it doesn’t overlap with your production VLANs. This VLAN is local to the MLAG peer group.
2. Setting Up the MLAG Peer-link Port-Channel
Next, we’ll configure the physical connection between MLAG peers:
configure
interface Port-Channel47
description MLAG_Peer_leaf-3b_Po47
switchport mode trunk
switchport trunk group MLAG
!
interface Ethernet 47/48
description MLAG_PEER_leaf-3b_Ethernet47/48
channel-group 47 mode active
no shutdown
After configuring, always verify with:
show interfaces status
show interfaces trunk
3. Establishing the Layer 3 Peering Network
Now for the peer-to-peer communication layer:
configure
interface vlan4094
description MLAG_PEER
mtu 1500
no autostate
ip address 10.1.255.10/31
Pro tip: The IP addressing here doesn’t need to be unique across your network – it’s only used for communication between these specific peers. However, it can be if that fits your design better.
4. Defining MLAG Domain Parameters
This is where we bring everything together:
configure
mlag configuration
domain-id Access_Pod3_AGG
local-interface Vlan4094
peer-address 10.1.255.11
peer-link Port-Channel47
reload-delay mlag 300
reload-delay non-mlag 330
exit
Key verification step: Always run show mlag
and show mlag interfaces
after this step.
5. Adding Member Devices
Finally, let’s look at how to add additional devices to your MLAG setup:
configure
interface Port-Channel51
description MEMBER-LEAF-3C_Po49
no shutdown
switchport
switchport trunk allowed vlan 10,310,320,330
switchport mode trunk
mlag 51
!
interface Ethernet51
description MEMBER-LEAF-3C_Ethernet49
channel-group 51 mode active
no shutdown
Critical note: The MLAG number must match on both peers for proper operation.
Troubleshooting Tips
When things don’t work as expected (and they sometimes won’t), focus on these common issues:
Peer Link
- Check physical connections
- Verify port-channel configuration
- Ensure VLAN configurations match
Configuration Inconsistencies
- Use
show mlag config-sanity
- Compare VLAN configurations
- Verify port-channel settings
Keepalive
- Verify peer IP connectivity
- Check VLAN 4094 configuration
- Ensure no autostate is configured
Best Practices for Success
Always Verify After Configuration
- Use show commands after each major step
- Don’t proceed until current step is verified
- Document any unexpected behavior
Maintain Configuration Symmetry
- Keep VLAN configurations identical
- Use consistent naming conventions
- Match port-channel configurations
Change Management
- Make changes during maintenance windows
- Have a rollback plan ready
- Test configurations in lab when possible
Conclusion
Whether you’re setting up a new network or maintaining an existing one, these steps will serve as a reliable guide for MLAG configuration. Keep this guide handy, and don’t forget to verify your work at each step – it’s the best way to ensure a smooth implementation.
Happy networking!
Leave a Reply